Google AppScript not executing after an 'On Change' to sheet

Anyone else experiencing the same with their google AppScripts?

I have an ‘On Change’ trigger on my sheet, but it doesn’t trigger the execution of my scripts, the last execution was 40mins with no errors.

Do you mean that changes to the sheet initiated by Glide are not causing the trigger to fire?

I just did a test, and it seems to be working as expected.

it was working before, and now is not without changing anything? or is it a new script and trigger?

yes thats correct, a change to my sheet via Glide should trigger my appscript but its not.

I just tested it again and nothing is being triggered, I have made no changes to my scripts or triggers.

is your trigger event type set to ‘On Change’ or ‘On Edit’?

it was working fine about an hour ago and since stopped working

So when you look in the execution log, you see nothing?

I see this, the last execution approx an hour ago my time.

I then make a change to my sheet, and no new executions are listed.

That’s odd. As I said, mine are working as expected. Are you seeing the changes in the sheet coming through from Glide?
The only thing I could suggest would be to create another (very simple) trigger as a test case, and see what happens. eg. Something like:

function onchange() {
  console.log("I'm alive!");

Also, perhaps check that your onChange trigger is still there and correctly configured?

yeah very strange…

I created a test function as you suggested, manually triggered via the editor as you can see on the screenshot, updated my Trigger settings and still not being triggered via a sheet edit.

how can I check to see if changes from my sheet are coming through?

What I meant was, if you make a change in Glide, do you see the change reflected in the Google Sheet?

ah, yes i see those changes coming through from glide.

I know this is an obvious question, but just trying to eliminate all possibilities… the trigger is still there, yes?

o you have any conditions for that trigger in the script?

No, this is the first line of my trigger function, i’m not seeing the debug line get written, nor there is an execution of the trigger in the logs.


  console.log('changeType: ', e.changeType);


yeah i do…

do you know how to re-trigger an authorization to allow the sheet to execute the scripts?

I have a feeling that it might an authorization issue.

try to delete the trigger, and add a new one… do you really need that (e) ?

I’d do as Uzo suggests. Delete it, add it again and then run it manually. If it has insufficient permissions then you should be prompted at that point.

A couple of other things to try that might help isolate the issue:

  • Does it work if you manually make a change in the sheet?
  • Does the same script work in a different Google Sheet?

perhaps I don’t need the (e) but it was working with it. I use it to check the type of event eg; INSERT_ROW, EDIT, etc then execute based on the value.

I tested an old glide app with a similar setup, it worked after i ran the script manually and requested me to approve the permissions. A change to the sheet via glide triggers the script fine.

The problem I have with my current app is that I can’t seem to figure out to re-approve the permissions, even after deleting a re-creating the trigger and manually running it, it doesn’t prompt me to approve permissions.

Is there any other way to manually trigger the prompt to approve permissions?