Glide • PDFMonkey Integration

Hi everybody,
I tried using PDF MONKEY integration. Everything is working perfectly. But creating line items is not working properly.
Please help me to fix this problem.

How are you creating the JSON?
It could be that the accents on the Vietnamese characters are breaking it.
Suggestion: copy the contents from your Json template column, and run it through JSON Lint to see if it is valid.

I also couldn’t get it to work, tried everything. The Glide integration is broken, it’s not recognising the JSON that is being passed (looks like it stringifies the JSON so it sees it as a string instead of pure JSON object). I ended up writing a Google Script and I still struggled to make it work, but I finally managed to figure it out by first parsing it before the whole payload is sent.

Glide will need to fix this integration on their side.

1 Like

I think there was a character change from " to \ " on PDFmonkey.

Yes, because it stringifies the payload thereby causing the extra characters. Glide has to fix it.

Instead of (for ex:) try name - we don’t support nested JSON for now.

1 Like

As Jeremy noted above, I don’t think they have had line items since the start. Your best bet would be having a variable that will contain those line items, in HTML format, and try to generate that HTML right inside Glide.

If that doesn’t work for you, then you’ll have to go back to an external service like Make to pass the line items to, and then call the PDFMonkey module to generate the file.