Generate CSV Integration fails with "Couldn't load plug-in"

Greetings All
Quick question - using the Generate CSV integration with a query - I have created action to open link once generated but am getting the message “Couldn’t load plug-in” (i am using Chrome browser).
Any suggestions please?

my action

chrome response

I get this all the time with Chrome too. I don’t know how to resolve it. I’ve been trying for months.

Do you have any ways of reproducing this reliably?

Do you have the table you’re rendering to csv loaded somewhere in the app at the use of that action or is never referenced before?

1 Like

@Robert_Petitto on those cases, can you verify if adding ?alt=media to the end of the csv url works in those “couldn’t load plugin-in” cases? We’re thinking it’s a issue in some chrome instances not able to load file types. If so we’ll put in a fix to the open link.

Hey @Jeremy — unfortunately that didn’t work. Here are some other things I’ve tried:

Ya definitely something going on with chrome (on mac exclusively?)

Can you run through and see if any of that helps? Do you have chrome updated regularly?

Yes, Chrome is updated. I went through this exact website just the other day in fact! Nothing worked :frowning:

Hi Both
Firstly @Jeremy let me confirm (if I understood your question correctly), the query referenced in the action is the same query that is the source for the collection displayed.

Secondly, I ran a check on whether chrome (on mac) was updated and once it was confirmed, I quit and restarted chrome and now the action is working! (Sorry I did not notice if my chrome version had changed after doing the check.)

But here you can see the action working!
Successful Generate CSV Integration

Will keep you posted if results going forward are not consistently successful.
Thank you

1 Like