The spreadsheet row could not be sent to Google Sheets

My app’s URL: theclass.app

I’m trying to feed sales done in a website to the App:Sales sheet with Zapier.

I get this message:
The spreadsheet row could not be sent to Google Sheets.
Google Sheets error: “There was an error writing to your Google sheet.”

Last Updated: Mar 02, 2020

Symptoms

After attempting to test a Google Sheets action, you may see an error that says “There was an error writing to your Google sheet.”

Causes

Zapier will show this error if something about your Google Sheet changed after you selected it initially. For example, if the name of the spreadsheet or a tab (worksheet) of the spreadsheet changed.

Does this have anything to do with Glide? Or is it a GSheets issue?

Its a Zapier issue with Google sheet not related to Glide and you’ll need to check with Zapier team.

Also you and try to copy the Zap and check if it will work because sometimes when you rename the google sheet or the spreadsheet itself

I tried adding data to that same sheet (App:Sales) now using Integromat, and it doesn’t work either.

  • The operation failed with an error. 400: INVALID_ARGUMENT - Requested writing within range [‘App: Sales’!A553], but tried writing to column [B]

@Mark @david is this Gsheet tab in some way only editable by Glide?

We’re not doing anything special to that sheet that should cause that, as far as I’m aware.

Strange that neither Zapier nor Integromat can add a row to that sheet…

I even tried sending the sales data from Stripe to another tab in GSheets, and then trying to copy the new row into a new row in App:Sales, and it didn’t work either.

I found this on Zapier’s help:

Possible causes:

  • Do you have a colon (:slight_smile: in your worksheet or spreadsheet title? If so, try removing it - colons in spreadsheet and worksheet titles can sometimes cause a Zap to malfunction.
    I guess if I take the colon off, Glide won’t work?