Set columns is not set if source column contains an empty(null) value

My app’s URL: https://setcolumn-problem.glideapp.io/ (can be copied)
@mark Will you look into this bug.

In this case, setcolumn does not set an empty (null) value if the column is a basic column (number) - but it does set the value if the column is a computed column (template column)
image

The data (company table) is like this

The two tables (company and Dynamical Links) are linked by a single value column
image

In the details view I have an inline list which will show SMS and Facebook link so I will expect that only SMS is shown for Apple and only Facebook for Google
Below you can see that for Google the SMS also shows up - and it carries the value from Apple when Apple has been clicked before-hand
image

image

The data for the inline liste used for Google is shown in the Dynamical links table. Notice that SMS carries the value from Apple

Possibly workaround: Use Setcolumn with “Clear value” before the actual Setcolumn with the wanted value. This is a very long way to take when you have 10 setvalue actions in 6 different screens - meaning 60 new setvalues to be done. And it used to work :frowning:

Related to this post:

1 Like

@Darren_Murphy could some of these be our problem?? :thinking:

Worth having a look at…

I have tried to boil down the problem instead of looking at a big app

how did you get that Set Columns into a * Rel as a single value column?
In my UX I have only the option to use This Item OR a relationship column.

Thanks!

@Mark_Turrell take a look inside the app. It is copyable

@Mark_Turrell

When you use a Single Value set to get the “whole row” this works as a single relation.

I hope this makes sense.

1 Like

And does that trick work @Santiago_Perez1? :upside_down_face:

I am like Mark trying to understand this Single Value column working as an indirect relation (and avoid creating a single relation as well). This kind of trick seems to be brought from Chuck Norris’ toolbox :rofl:

What about @Krivo if you use a new but simple relation in your Set Column action?

Would it fix the issue?

Feliz día!

@gvalero

It works fine. I’ve used it before.

1 Like

Similar problem here.

1 Like

@Santiago_Perez1 I have also tried to use (single) relation and lookup. This is the same result. Empty (null) values are not written to the destination when using Set Column.

1 Like

@Krivo

Yes, it happens especially when there are several steps to it. I do not know what causes it but I have had it happen. When it is only one step, it works fine.

And moreover, even by using Column Values as attempt to solve this workaround does not work also when the source value is empty (in my case i need to clear the Date&time Column by some condition through calculated Column, which builds just for this workaround). SetColumns still not work also even by “Clear value” options(

The problem is caused by Set column action. If the source column is empty (and a basic column) then the empty value is not set on the destination

Have a look here:

I have created a new app where the user has to sign-in. The problem is precisely the same as a public app

1 Like

So an even simpler case. No user specific value.

url: https://setcolumnsimple.glideapp.io/

@mark i have already put in a ticket - but the bug should be easy to see in this case

1 Like

Got it. Will fix. Thank you!

1 Like

Fix will ship Friday.

4 Likes

Krivo, Mark,
Unfortunately in my App Set Column Action doesn’t work even in case the source Column has a non empty value (the Current Date Time in source calculated Field).
The situation looks like similar but only Destination Column is empty, not the source.
Also it does not work when i tried to use Clear Value in Set Column Action - in any kind of Forms (Edit\Add).

Found only way to force the Set Column work is using it by Button Actions, not by On Submit in Forms.

After posting this 10 min later, it start work again). Only changes was i set manually the Destination Column, then manually cleared it up. And Set Column started to work in this case…