Problem with app icons

Last night I started building a few new apps, some that I started from scratch via my own Google Sheet, and a few others that I copied over from Glide Templates.

The issue that I ran into is that when I uploaded my own icon (using a png image, and I also tried a jpg image), it is no longer populating as a favicon. It shows in the Glide UI (where you upload it) and it shows in the app UI (when you copy the link and view the icon next to the simulated phone in the desktop browser). However, it does not populate anymore in the desktop browser tab (where favicons are normally displayed). The icon is also not populating when trying to “Add to Home Screen” on an iPhone (it just shows a thumbnail of the opening tab). The icon is also not populating on Android devices when trying to “Add to Home Screen” (it just shows a single letter, based on the app name). I first noticed this bug occurring last night to any new apps that I was creating and the problem still persists now, roughly 17 hours later. I have cleared cache/cookies, deleted browsing history, uninstalled/re-installed the apps, tried using incognito windows, disabled ad-blockers, used a variety of different browsers on different types of devices, and the issue still persists.

I have made many apps prior to these apps I’m referencing and this has never occurred. I could always copy over a template or start from scratch, input my own data, restructure the UI, name the app, upload my own icon, adjust any relevant settings, publish the app, then add it to my iPhone to test it and analyze it, and when adding it to the home screen, it would always populate the icon that I uploaded (this was also true when viewed on a desktop browser or Android device).

Being that this issue appears to be irrelevant to my particular app(s) (and appears to be happening for any new apps that are created), anybody who can help look into this, just grab a template or start an app from scratch, make a quick build, upload any icon, publish it, then see if you are getting the same issue as me. Perhaps some people have had varying times as to when their uploaded icons have “appeared” in the proper locations, but if everyone if currently seeing the same issue as I just mentioned, and can remember their prior experiences to gauge now vs before, we can see if it is a true bug that Glide can look into.

Please note:

  1. This issue is only occurring for newly created apps with uploaded icons. This issue is not occurring with the built-in icons/emojis provided by Glide (they populate right away in all the locations mentioned earlier). This issue is also not relevant to any previously created apps.
  2. This issue is separate from another similar issue that occurs when you have already set your app icon in Glide, either via an uploaded one or a built-in one, then add your app to your home screen (particularly on an iPhone), then decide to change your app icon in Glide at a later date, and the app icon on your iPhone doesn’t always refresh with the new, updated app icon (uninstalling the app and clearing browser data sometimes works but not always).

Whew, thanks for reading this “essay” and I look forward to your replies.

3 Likes

Happening to me too. I don’t know why Glide isn’t addressing this issue or trying to resolve it.

Sorry to hear that, but at least good to know that others are experiencing the same thing. Hopefully Glide sees this soon. The main reason that this issue is troublesome, is that I have now completed those apps that I started last night, but I am reluctant to “release” them, because of the user experience when installing my apps. They wont be able to see my icons and it will appear as a “bookmark” to them, stealing from the professionalism.

1 Like

I am having the same problem. Like you, I’ve tried everything. I have made new apps, but I’ve also updated the icons for a few apps I had before. The icons for apps made before won’t change to the new version. The new apps won’t take the uploaded icon. They’re stuck with the stock images.

Like I said to @wicked, I’m sorry to hear that you’re experiencing this issue as well, but hopefully with more people confirming, it can get resolved quicker.

All of my previously created apps luckily have the correct icons, so I haven’t had any recent need to go back and change them, but either way, I’ll take note of your experience and hold off until this bug has been fixed.

Exactly.

This is happening for me as well. Just as you described it. Really frustrating! I was hoping to launch my app on Saturday!

Yeah, you’re basically in the same situation that I’m in. I have a few newly completed apps that are ready to launch, but there’s no way I’d release them without proper icons. :frowning_face:

1 Like

Também estou com o mesmo problema, fica muito feio

Espero que seja corrigido em breve. :pray:

Sounds like a general bug, looking into it now.

4 Likes

Much appreciated. Thanks for the quick response.

I have the same problem, I’m glad to know that they are already solving it.

It’s fixed now.

3 Likes

Thanks for addressing this so quickly. Just double checked on my end and everything is working properly now. :slightly_smiling_face:

1 Like

Things are now working on my end! Thanks for fixing this!

@david @Mark

I’m having some problems with this.

  • Brazil, Sao Paulo
  • Iphone 7

image

Looks like you are not using a square image for your app icon?

@Jason Not but… why glide’s showing the pic fitted in the icon in the editor?