One value is missing from a TEMPLATE field

Hello.
I have an assembled field that ends up being output as Rich text. The field has a number of variable values that are derived from the raw data.
And one value for some reason shows up in the data book, but is missing when it is output to the application.
The data book: image
Application: image
At the same time, elsewhere in the same app and on another sheet in the same book, I also build the same pattern and it displays correctly.
I guess there is some bug.

I assume that you are using replacements in your template column - can you show what that looks like?

Yes of course.
The problem is that the data look fine in the book. But when I output it, it doesn’t. I’ve tried different variants of variable names - with and without percent sign, and in English - no difference. Everywhere I use a percent sign and in Cyrillic, and everything is fine.

Yes, I see. I’d guess that the Cyrillic character set is somehow tripping Glide up, but as you say it works elsewhere in your app. So I really don’t know, sorry.
I generally use curly brackets {} to enclose my template variables. I doubt that will make any difference here, but you could give it a try.

If the problem is Cyrillic, then:

  1. why do the other 2 variables behave correctly?
  2. why does the substitution on the sheet work correctly? The problem is only with the output in the application
  3. why does the exact same pattern work elsewhere?

I tried replacing the Cyrillic name with the Latin one like “30_DAYS” and “30DAYS” - the result is the same.

Maybe the developers will take a look and fix it if it’s a bug :slight_smile: