Inline Lists not working

My app’s URL: https://adventure.glideapp.io/

Hi. My app’s inline lists have stopped working today. They were fine earlier this week, and no changes have been made to the sheet file nor the glide settings of the app to cause the change.

Before, one would click one of the icons and it would proceed to another level of options. Now it does nothing. This happens for both the Adventure tab, and the second level of the Sections tab.
Please advise

May we know what’s the action tied to those inline lists?

A new set/level of options appear
Each icon, by virtue of the inline list, is the parent of a set of children icons
Here is a video of an older version of the app (whereby the inline list looks like a list rather than a matrix of icons), but the architecture and actions/reactions are still the same: https://photos.app.goo.gl/ocLT7SZmyduigsev6

I should also point out that this is not confined to this one app. I have another app that has the same problem. ie it isn’t due to changes by me that has caused this malfunction

I seem to have resolved it by just creating another inline list, and delete the old one.
Bizarre

1 Like

So those actions seem to be link to screen with the source being a relation?

@ThinhDinh, I don’t believe this issue is limited to what @Robert_Chaney has experienced. We have several apps within our account experiencing lost actions. There are 7 apps in our account and every single one has lost the Show New Screen action from inline lists on the Home screen. This issue appears to limited to inline lists on the Home screen only; our inline lists on sub/interior screens work fine.

Just like Robert’s issue, none of these apps had been worked on and no settings were changed. While we could recreate all of these screens (not ideal and doesn’t fix the root problem), there is obviously something more substantial going on here.

Can this issue please be escalated? Thx

cc: @Natalie_Fruciano

1 Like

What do you see as actions on those inline lists after the “error”?

Hi, @ThinhDinh. To put it simply, this bug removes the Show New Screen action and changes it to none. All 7 of the inline lists on this Home Screen have the same issue.

1 Like

Please submit a ticket here.

https://glide-help.zendesk.com/hc/en-us/requests/new

1 Like

Could I get a support link to an app where this happened, ideally where the screen hasn’t been rebuilt yet?

Hi, @Mark. Here are a couple. FYI, the first one is what I included in the zen desk ticket submitted a few days ago and Jesus said, “The engineering team told us that The support link goes to an app that doesn’t exist anymore.” I appreciate you looking into this. Thx

https://go.glideapps.com/support/6b91c320-73cb-4955-b6e3-12a3395edc34

https://go.glideapps.com/support/d0a43fa5-7f4e-4df5-8b13-944ee4a20179

1 Like

Hi, @Mark. It appears the bug is more widespread than originally thought. We also have inline list on interior/sub screens that have had their Actions removed and some button components are no longer displaying in the app—see explanations below. These additional issues are again widespread—they have occurred in all 7 of the Maricopa Healthy apps in our account.

Have you made any headway on what could be the cause and is their any way to revert apps back to a certain date/time within the Glide builder on the backend? Thx

Inline List Actions Missing on Sub Screens
Go to our Home screen > Active > choose Baseball > and you’ll see an inline list labeled Parks with Baseball. All of the actions in this list have been changed to Action > None without us making any changes. This same issue is repeated for all of the activities listed in the parent Active section. Note, although unrelated to the bug, these sub screen lists were originally built using relational formulas in Google Sheets (almost two years ago) and have not yet been converted to use the new Visibility condition available in Glide.

Missing Button Components
Go to our Home screen > Active > choose any activity > Leagues and Meetups > choose any city > you’ll see the Button—Find a Meetup component no longer displays under the Meetups description. Double checking the settings and options for this component you’ll see there is no Visibility setting turning the component off and there is a destination URL listed in the data sheet so the button should be displayed.

1 Like

@gannonatwork we’re continuing to look into this issue.

@gannonatwork I looked at Maricopa Healthy, and there have not been actions on the Inline Lists on the main tab since at least April. I didn’t look back further. I can look back further and restore the app to some old state, but there have been app edits since which would get lost.

Actually, I have another hypotheses - I’ll report back.

Hi. I raised this issue initially, and I have found that not only inline lists, but also Buttons, do not work.
It seems that maybe because of Glide2.0, extra functionality or alternative/new ways of making the settings for the components, with extra drop-downs etc, has meant that the older components cannot cope or talk to Glide2.0, so instead just fail.
The only solution is to create a new (but identical) component, setting it up using the newer drop downs and settings.

@gannonatwork We introduced two bugs about a week and a half ago which affect very old apps, and which you’re both experiencing:

  • The one where the Open Link action doesn’t work. This will be fixed later today.
  • The missing Show Detail Screen action on the Inline List. Unfortunately we can’t fix that without now breaking newer apps. This only affects the Show Detail Screen action, and the detail screen is still there, so if you set the action now it’ll be like it was before.

My apologies.

6 Likes

Hi, @Mark. I really appreciate you stepping in and figuring out the root cause of both issues. We’ll keep an eye out for the Open Link action fix and will move forward with reconfiguring the Show Detail screen actions. Such good news that we don’t have to rebuild screens. Thanks again!

1 Like

Closing due to inactivity.