Inline list - appears differently for the same user between UX and actual app

I am using the user’s email in the UX… and I see three people available (with the correct visibility)
BUT on the user device, they only see themselves

No row owners…

what might be wrong? Thanks

What filters are on that list?

Task_video is true & signed in = true

That’s it :frowning:

I imagine it’s something to do with that, but without seeing it, I couldn’t tell you.

Is it possible that first filter could contain empty cells (i.e. filter could be “is not false” to get true and empty values). Not sure if that makes sense though for the scenario.

Any user specific columns in your filter?

2 Likes
  1. no usc-columns in the filter
  2. I changed the order of the filters - still does not work

And - if i set the Role = Admin then users can see the items in the list correctly - on their devices (I can see them correctly in the UX when I pretend to be them)

What I can think of is that I used to have row owners in the Agent sheet, then I removed it. But even that does not make sense…

I then checked User Profiles. The Role was set to ‘Role’ … even though it is not used in the Tab I am in, nor in the Filter.

Very bizarre…

And I made the inline list work by REMOVING Role = Role in the User Profile.

Back to expected functionality :slight_smile:

1 Like

ok - that method worked for some and not others… but thanks to @Darren_Murphy, we now know the issue:

  1. in my user profile table (Agents) I used to have Row Owners…
  2. … on an array column - Owner 1 (email), Owner 2, Owner 3
  3. when I took row owners off the array… ARGH! it removed row owners from the LAST column Owners 3, and kept it for the first two columns (without the UX showing that this was the case)

Solution

  1. rename the columns in GS - Owner 1, Owners 2, Ownerz 3
  2. then in Glide, see that Row Owners was still applied to 1 and 2
  3. remove row owners
  4. check to make sure the inline list works
  5. rename the columns back to the original names in GS

Tada, it now actually works :slight_smile:

mmm, this is a sneaky one, and very difficult to troubleshoot if you haven’t seen it before.
This is the second time I’ve seen it - in your app last night, and I also saw it in one of my own apps recently.

I just tried to replicate the issue in a test app, but wasn’t able to. So there must be a very specific set of pre-conditions required in order to trigger the behaviour :man_shrugging:

1 Like