Glide Table data not syncing in production

I have set a User to “Premium” in my app in User Profiles Sheet. In the builder, things are fine. However, in the production link, it is as though Glide table is not synced. The User is still turning out to be a normal user. Is it a bug? Any help appreciated.

It was working fine till I had user profiles in Google Sheets. After moving to GLide table it has stopped working.

How are you setting a user to “Premium”? I guess it’s a boolean/text column?

Hi. Yes, it is a text column.

Can you include a video of the bug in action? Thank you.

Visibility Condition
image

Glide Table

Used date math to set end date and text column to indicate premium.

Is this a Private Pro app, and are you setting the user to “premium” via the use of Roles?

I do know that Roles can only be set via the app when a new user is created. If you need to change the role of an existing user, then you must do it manually - either by editing the data directly in the GDE or the GSheet.

This is a known limitation, and is mentioned in the docs:

Dear Darren,

No, I am just editing the data in Glide table. I am not using a private pro app or making use of Roles.

You probably need to add “email is signed-in user” to that visibility condition.

(and yes, you can probably ignore my previous reply)

Oh I see. Let me try it and get back. Thanks a lot.

Dear Darren,

I changed it.
image

But, it still doesn’t work. It works on the builder. But, it doesn’t work on production (installed on my phone).

The App is a “Public with E-mail” app. So users have to anyways sign in. Why should I use a Signed in User? However, the issue still persists even after including it. I am using Row owners for the Email in the User profile sheet.

What I am trying to do is simple. Just added 2 users in the user profile sheet and trying to show or not show a tab based on a Text column and a date column.

It works perfectly in Glide Builder. Just that it doesn’t work in production. Stuck with it for more than a day. Hope it will be resolved soon.

Actually, if you are using row owners, then that “signed-in user” filter isn’t required.
I can’t explain why it would work in the builder but not in the app.
I assume that you’ve tried re-installing the app? (that shouldn’t be necessary, but might be worth a try).

I am just using it in the browser and re-loading it. Hence, no question of re-installing i guess. I tried opening the app in incognito and also cleared cache.

Okay, at this point I don’t really have anything else to suggest other than perhaps if you can make a video (as @ThinhDinh suggested) that shows how you have configured everything.

Dear Darren,

Currently I am unable able to make a video.

But, if it is working fine with Google sheets, why is it not working with GLide Tables is my question.

Google sheets in both builder and production are working fine. The GLide table in the builder is perfect.

The problem is in the glide table with production.

The configuration is the same throughout.

Builder Snapshot : User is displayed perfectly as Premium User.

Production Snapshot : User is shown as Basic

This bug still exists. Somebody please help.

For now, I am using google sheets for user profiles as I do not want to take any risk. Glibe tables seems not ready yet.

Please create a support ticket with all required info so the Support Team can help you.

https://glide-help.zendesk.com/hc/en-us/requests/new