Glide freezes

Hey everyone!

I have my glide dashboard and builder freezing for the last 4-5 hours. I cannot work in the builder at all, tried 2 different computers.

Does anyone have the same problem?

Within the past couple weeks I’ve noticed apps taking a LONG time initiate and at times become non-interactive in the builder. Typically I have to close chrome and relaunch.

2 Likes

Actually yeah, same. I’ve just been assuming that it’s me pushing the limits by having a bajillion tabs going at the same time. I’ve just upgraded to a new Macbook with double the RAM, and waiting to see if that makes things better…

I am having the same problem. My apps are not loading in the dashboard and i am unable to work on them.
I have restarted my chrome and that has not helped. I also got a sign-in error earlier.

Is there perhaps a real-time platform monitor where we can see the status of the platform

This was my assumption as well but it appears to be a more systemic issue

yes, there is.

https://status.glideapps.com/

thank you.

I followed the link and all seem s to be well with the platform.

I will do a full restart and see if that solves my problems.

I have done a full restart an i am still experiencing the same issue.

I do note that a message is appearing stating that the dashboard is waiting for firestore.

is their a configuration in my chrome browser that i should enable, perhaps?

I will look around the security settings.

If there is, I’d like to know it as well

Try deleting any Glide related cookies

I don’t think that the problem is in browser/cookies/devices. I have tried to use 2 different computers with different web browsers today and the problem have been better for a couple of hours but now it has appeared again.

The main problems are:

  1. Apps in the dashboard are loading veery long and it’s almost impossible to open them, clicks do nothing, apps loading takes for some minutes sometimes
  2. It’s almost impossibe to save a custom action, the save button just do nothing
1 Like

Agreed. Same behavior. Safari is slightly better than Chrome, though.

Getting the same issue here. I have to close and reopen the Dashboard multiple times a day. Makes doing live build sessions with users problematic to say the least.

We think we know what the issue is, and will release a potential fix today. cc @Daniel_Sweet

5 Likes

We have shipped the potential fix. Please try it.

3 Likes

The builder issue is now fixed but the app loading (in the builder) is very slow and especially if we have a Role set for rows it takes longer than usual I have to wait around 2 mins to have the data load