Duplicating or Copy & Paste components are losing visibility - Bug or normal?

I don’t know if this is an error/bug but I’d like to keep the visibility when we duplicate or copy&paste a component :confused:

Is it normal @Mark @Jason ?

10 Likes

I’ve noticed this too. It’s as if the duplicated component was not duplicated at all but added as a new component. The same happens when I duplicate the others like an inline list. They revert to default/factory settings :frowning:

1 Like

@Lucas_Pires

Could you submit a ticket for this please?

Thanks!

1 Like

I also noticed this today. Seems like a bug.

1 Like

Noticed this the other day. It’s def a bug. Did you submit a ticket yet, @Lucas_Pires ?

1 Like

No yet. Didn’t have time to it

Engineering will fix it.

6 Likes

Thanks, I really need it!

1 Like

It is making life hell…

6 Likes

Does anyone know if this was fixed?

Hi @popina :wave:

Welcome to the community :partying_face:

For me no. I think still not fixed

1 Like

Another oddity also occurs when the entry component is copied from the form screen to the detail screen.

1 Like

:thinking: wierd

3 Likes

How is it going @SantiagoPerez? It’s a nightmare :frowning:

Engineering has been working on a fix that will be out soon.

6 Likes

Thanks for the quick answer :slight_smile: @SantiagoPerez

This bug is hell!
I have to finish an application today, but I need to duplicate about 60 components, but if I have to do one by one setting the visibilities every time, I’ll freak out… :_(

3 Likes

:pleading_face::pensive:

3 Likes

Hoping this gets fixed soon!

Now copying components and their visibility has been fixed.
How about “required” on the entry component?

5 Likes