Components disappeared

Hello everyone,

How is everyone doing? I have been away since early July and so much has happened in Glide, wow.

I just signed in to the builder of one of my apps (https://paulsrentals.glideapp.io/, pro app) which I hadn’t edited in weeks.

All components other than the first one were deleted/removed/are not there.

Is this a known bug?

Thanks!

3 Likes

P.S. It’s nice to be back. I’ve missed everyone.

It’s going to take a while to catch up on all the incredible changes of the past few weeks.

3 Likes

Welcome back Nathanael, hopefully things are going well over there.

Not sure about disappearing components, apart from syncing issues I can’t think of a problem.

2 Likes

@ThinhDinh Things here in Europe are fine. I took a few weeks off. I’m traveling back home a little later today.

I thought it was a syncing issue as well, until I noticed in the builder that the components are just gone.

Want to here a funny one?

I usually have 3 versions for each of my apps: production, staging, backup.

I hadn’t edited this particular app in a while. Went into the builder and was discovering a lot of new features: the new settings layout, new components, etc. I replaced a few empty text components with separators (nice component). Because I made a few changes, I deleted the backup and made a new backup by duplicating the app.

And then only did I realize that components were gone. And so was my backup. How ironic :see_no_evil: :wink:

Maybe @Mark or support can revert to an earlier version and if not, I’ll just redo it.

3 Likes

Can you please share with us what happened when you find out from support? That’s pretty scary. :worried:

@Deena
I trust I’m the one who did something wrong. No idea how I did it. I wouldn’t know how to reproduce that even if I wanted to :joy:

1 Like

Hi @Mark, any idea if this is a bug or an error on my part?

  • App: https://paulsrentals.glideapp.io/
  • Tab: Properties --> Enter any elements from the tiles list
  • Problem: At least 4-5 components disappeared. Only the very top one remains.
  • Possible triggers:
    (1) I was playing around with “Select” and “Play” modes since these were new to me (I hadn’t signed in since late June).
    (2) During my session in the builder, I added selector components and deleted text components in other tabs.

I could have done something wrong, but it’s hard for me to see how I could have inadvertently deleted 4-5+ components.

2 Likes

Look at this

The bug is known an reported. You can avoid this behavior in live mode editing.

I had the same thing that you. Some of my components disappeared except the first one.

I hope it’s the same error with the delete key in edit mode which @Mark suggested in my thread.

Thanks @darder for help, what you say makes sense. I think I understand what happened in my app.

In reference to this post, I think something similar happened to me too.

For @Mark’s team, I believe I did the following:

  • I entered the production version of my app.
  • In “Play” mode, I went to the Properties tab.
  • I entered an element.
  • There I switched to “Select” mode.
  • I’m pretty sure I didn’t edit, add or remove any components there.
  • I then switched to another tab.
  • There I edited text components which I had purposefully left empty to create spacing.
  • I hit delete/backspace a few times to change the spacing: nothing happened.
  • I deleted the texts components using the mouse.
  • I added separator components and adjusted their settings to my liking (s/m/l).
  • I returned to the Glide dashboard and deleted my backups of the app.
  • I duplicated my production app to create a new backup.
  • Upon entering the production app, I noticed that components in the elements of the Properties tab were gone.

In hindsight, I realize that in “Select” mode, I believe from another tab, I must have deleted components from the first tab.

I hope this might help.

3 Likes

@nathanaelb wonder where you were. Well then soon time for another meetup😜

Hi @Krivo! It is so good to be back. I missed Glide so much. I tried to sign into the forum but I definitely could not be active or even keep up with everything that has happened since early July.

And so I signed into one of my apps, started playing around with new features, and boom! :joy:

1 Like

We think this happened because of a bug that caused the Delete/Backpace key to delete components, even when editing text. It should only delete a component you have selected in “Select Mode”. The bug has been fixed. Apologies for the trouble it caused.

2 Likes

Hi @Mark, thanks for taking the time to reply.

In my case, it was no problem at all. I noticed the bug almost immediately, my client didn’t and it took me only a few minutes to rebuild.

1 Like