Cannot add data to the Glide table and Spreadsheet

Hello

It seems like my app cannot write anymore on the Spreadsheet and Glide table.
It was working yesterday, but is not anymore.
I have the Pro App, and I have not reached the row limit (4,172/25,000).
I have checked the available empty rows in my sheet and the data also didn’t being added to the very bottom of my sheet.
Anyone else has had this problem before?

Thank you

My app’s URL: Glide

Please try the following:

  1. Refresh your browser.
  2. Try logging out of Glide completely and logging back in again, then refresh.

If you are using certain functions like ARRAYFORMULA(), or you have a column formatted as a checkbox (Insert>>Checkbox), when adding rows via the app, Glide will append rows after all of the seemingly empty rows, because these rows are not empty. So, if you think you are missing data on the Google Sheet that you see in the Glide Data browser, look at the very bottom of your Google Sheet. It is safe to delete all empty rows as Glide will append new rows as needed.

Another suggestion is to make a copy of your Google Sheet in Google. Then go to Settings/Data Data Source and select that new sheet as your data source.

If the issue persists please create a screen recording that shows the data row in the Glide builder that is not in the sheet, and then click on the edit sheet button and show the same sheet and the area of the sheet you would expect the data row to show. Also, scroll down to the last row of the sheet to make sure it’s not there. You can use something like https://loom.com/ or any other screen recording software.

If all of this fails create a Support Ticket using this form.

2 Likes

Thank you George for your reply.
I have tried your suggestions to refresh my browser, logging out Glide completely and back again/refersh, and delete all empty rows… but the issue stil persists…

Next I will try to make a copy of my Google sheet then replace my data source…
I will report again wheter this will work or not.
Thanks

I have tried your suggestion to make a copy of my Google Sheet in Google Drive and renamed it. Then I went to Settings/Data/Data Source and select my new sheet as data source. Unfortunately the problems is still there, the data didn’t show up on the Glide Table and on the Google sheet.

Here is the video record that showing the issue:

You didn’t show the configuration on the form, and specifically which sheet it is writing to.
My guess would be that it’s not writing to the sheet you think it is, but instead is just overwriting the same row over and over again in another sheet - perhaps your User Profiles sheet?

Yes, I didn’t show the configuration on the form. But, I have checked all the configurations, and they are writing to the destination sheet that I want to.
I have created a Support Ticket using the given form from George. Fortunately, the issue/error disappears, and now I can add data rows again through forms in my app normally.
Thank you, George and Darren_Murphy, for the suggestions and responses.