App won't delete User data

Hi gliders.

I know it’s probably not something we may try every now and then but did anyone else have a problem with deleting User data from the App.

I have deleted the row from User profile sheet and went to the data source but I get an error that the email still exists in the table.
Could this be cause by rows being deleted and then coming back which usually happens when you are deleting a couple of rows at once?
Funny thing though is I was only deleting 1 row this time and yet it seems the row is there somewhere still not able to be deleted from glide. Any suggestions?

I’ve never actually tried it, but I believe the correct way to delete a user is with this option:

Doing it that way should ensure that any internal data associated with the user (user specific data, etc) is also removed.

Did you try that?

2 Likes

Yes, I tried that and it gave me the message that I must first delete the user from the user profile table and even after deleting the row with the email address and the user data, it still says the row cannot be deleted because the user is still on the table.
I am now puzzled.
Just as a test, I tried deleting an email address that I know is not part of the table and it gave a message that the email is not part of the table. I just wanted to check that the error is not by default.
I don’t know if this is isolated only to my App. But I will try another one of my Pro Apps just to see if it’s just this one App or others as well.

Does your User Profiles use a Google Sheet or Glide table?

I just did a test with one of my (Private Pro) apps that uses a Google Sheet for User Profiles. Did the following:

  • Deleted the users row from the Google Sheet
  • Initiated a sheet sync from Glide, and confirmed that the user row had disappeared from Glide.
  • Deleted the users data using the Settings → Data → Delete Data option.

All seemed to work as expected. Can’t do a test with an app that uses a Glide Table for User Profiles, as I never do that.

2 Likes

I initially had my user profile table as a Google sheet then I changed to a glide table because there seemed to be sync problems especially when there are a few people registering on the platform especially considering I used Mr @Robert_Petitto method of onboarding where you use the “Has Profile” increment and then submit and move to another screen.
The issues prompted me to change to a glide table and only then did I realise this issue of not being able to delete data because I wanted to test the onboarding process with one of my test email addresses that were already using the App and even though I deleted the row in both the GS & the Glide table and then refreshed, it still won’t delete the data. It must be “cached” somewhere between my glide table data and the glide server (if there is anything like that) but it (User data) is “ghosting” somewhere in-between and I can’t…

I assume that you’ve tried the usual stuff such as emptying your cache and deleting Glide related cookies, and refreshing your browser?

I didn’t try that. I will try it later on. For now I want to focus on something that works so that my energy is not drained. I want some guaranteed wins for today :grinning:.
Thanks for entertaining my mini “vent” :blush:

1 Like